プログラミング、ガジェット、趣味ネタを配信するブログ

UnrealEngine プログラミング

【UE4】VisualStudio2017でVXGIをビルドした時にエラーが出てしまう

投稿日:2018年12月1日 更新日:

VisualStudio2017でVXGIをビルドした時にエラーが出てしまったので、
解決方法ではないですが、実行できるところまで確認ができたのでメモしておきます。

○ 対処方法

VisualStudio2017では起動できなかったので、VisualStudio2015を使用してビルドしたところ
正常にビルドできました。

※補足ですが
「Setup.bat」を使用し必要データを取得した後、
「GenerateProjectFiles.bat」を実行してソリューションを作成して
そのソリューションのプロジェクトを見たところ(2015)と書いてあったので、
2015用にプロジェクトが作成されているみたいです。

ですが、「GenerateProjectFiles.bat -2017」で引数にVisualStudioのバージョンを
設定してからビルドしても私の環境ではコンパイルエラーが出てしまいました。

VisualStudioを管理者権限で起動してビルドを行うことで、コンパイルエラーが出なくなりました。

-UnrealEngine, プログラミング

執筆者:


comment

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

関連記事

no image

【C#】WPFのAvalonDockで起動時にDocumentWindowを表示させる手順について

【前提条件】 AvalonDockUtilのライブラリを使用しています。 ViewModelクラスをWorkspaceBaseで継承します。 WorkspaceBase::NewDocument関数を …

「Tortoise Git」のコミットとプッシュでデータをアップする方法

「Tortoise Git」を使用して作業フォルダのデータをGithubプロジェクトにアップして更新していく必要があります。 今回はそのデータをアップする方法を紹介していきます。   ○ G …

no image

VisualStudioでIncrediBuild FreeDev版を使用する方法

IncrediBuildを個人で使用する方法を説明します。 まず初めにIncrediBuildとは何かということをざっくりと説明しようと思います。   〇 IncrediBuildとは ソー …

【UE4】アセットは古いバージョンへ移行できないみたい

メモ程度なのですが、 アセット(コンテンツ)は新しいバージョンから古いバージョンへ移行(Migrate)で持って行っても アセットが表示されないようです。。。 できない理由はおそらく、新しいバージョン …

no image

【Unity】Standard Assets のバーチャルパッドを使ってみよう!

無料で配布されているStandart Assetsのバーチャルパッドを使用する方法をまとめていきます。 動作確認環境 ・Unity 5.6.3p1 ・Standard Assets Version:1 …

スポンサー 人気記事 最近の投稿